Orders API is failing

Incident Report for Toast API

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:07 EDT

Monitoring

Our APIs have recovered and are fully available. We'll continue to monitor our systems.
Posted Oct 20, 2025 - 20:08 EDT

Update

All APIs are back online now, except for the Orders API. Endpoints in the Orders API will return 503 error responses for a while longer.
Posted Oct 20, 2025 - 19:33 EDT

Identified

Our APIs will be returning 429s as capacity is scaled and systems are variously brought back online. We're leaving the incident as open and APIs an experiencing major outages.
Posted Oct 20, 2025 - 17:43 EDT

Update

We are continuing to investigate this issue and will post updates here.
Posted Oct 20, 2025 - 16:55 EDT

Investigating

The Orders API is currently down. All requests to the Orders API will return 503 errors. We're investigating the situation and will update here.
Posted Oct 20, 2025 - 15:34 EDT
This incident affected: Cash Management API, Config API, Credit Card API, CRM API, Gift Cards API, Labor API, Loyalty API, Menu API, Order API, Partners API and Webhook, Restaurants API, and Stock API and Webhook.